Sonic Lost World (Wii U, 3DS, PC) Megathread

Discussion in 'General Sonic Discussion' started by TimmiT, May 17, 2013.

  1. SF94

    SF94

    Tech Member
    775
    2
    18
    Utah
    SA1/2 hax
    No. It doesn't have exclusive fullscreen and defaults to upscaled 720p, but it will render at whatever resolution you put it at... just scaled to your desktop resolution in borderless window, whether that be up or down.
     
  2. It isn't just you. Platforming and killing enemies feels so awkward. There literally is no flow to this game (as I've stated before).
     
  3. Blue Blood

    Blue Blood

    Member
    4,688
    16
    18
    Lost World had needlessly cumbersome and unintuitive controls for a platformer, that are also poorly explained by the game itself. It's a recipe for a real mess. Then you factor in the the three types of homing attack (standard, kick and charged) that all only work on specific enemies and it only makes matters worse. The level design also doesn't flow a lot of the time due to the overuse of springs, invisible springs and dash panels undermining the tiered running speeds and parkour.

    Once you know the game very well and have memorised it to a tee, it's brilliantly good fun to play some of the levels (WH1, DR1...). You'll know how to swerve slightly to avoid the automatic elements and use the parkour to really get great speed and flow. Plus the spin dash is an absolute beast in some areas. It's essentially a more engaging version of the boost. But to get to that level you have to know the game like the back of your hand and still avoid the crappy design choices.

    Basically there's something of real value in the game, a real sweet spot that SEGA just failed to hit.
     
  4. TimmiT

    TimmiT

    ¯\_(ツ)_/¯ Member
    Using Windows 10 and I still have the issue with both games. Was there anything else you did that might have somehow fixed it?

    EDIT: Not sure where it came from (it was linked on the Steam forums), but apparently this will help put less load on the CPU: http://pastebin.com/Qs2KKYG7

    Might be helpful if you have framerate problems.

    EDIT 2: I can confirm that it improves the framerate. Went up by about 8-10 fps for me. Not to the point of it being 60fps, but still, it's an improvement.
     
  5. Azookara

    Azookara

    take it from me, little buddy Member
    2,997
    30
    28
    Meowth's party
    hoboagogo?
    I dunno what's up on my end but Generations runs fine at a very stable framerate but SLW lags to all hell and back. There's probably a good reason for that, but I'm not sure what it is.
     
  6. TimmiT

    TimmiT

    ¯\_(ツ)_/¯ Member
    With Lost World the game's speed is tied to the game's framerate, unlike Generations where there's frame skipping. That being said, I imagine that if you could run Generations at 30fps, that it should be possible to run Lost World at 60.
     
  7. Azookara

    Azookara

    take it from me, little buddy Member
    2,997
    30
    28
    Meowth's party
    hoboagogo?
    Yeah and it can run Gens at 30 IIRC (never remember any significant lag, might want to look into it again and make sure I remember right) so SLW running so slowly is definitely.. something.

    I mean it runs fine at times but just chugs and chugs at others. IDK.

    Also this game is only getting worse with every extra playthrough I do of it, lol. Last night it felt like a total trainwreck, though then again I was also playing on a keyboard.
     
  8. GeneHF

    GeneHF

    SEGA-ier than you'll potentially ever be. Site Staff
    8,387
    0
    16
    Scenic Studiopolis
    Complete Global Conquest
    If someone would be willing to donate a copy of the game, I can test a few things out in the game on my PC. :v:

    Don't actually do this, I'll feel awful about it.
     
  9. MykonosFan

    MykonosFan

    MODE CHANGE. Moderator
    3,287
    0
    16
    WV
    I can get a full 60 at 1920x1080 now thanks to right-clicking and running as administrator combined with an overdue update for Nvidia GeForce Experience. That...works, I guess?
     
  10. Running as administrator has absolutely nothing to do with the games' (or any, for that matter) frame rate.
     
  11. MykonosFan

    MykonosFan

    MODE CHANGE. Moderator
    3,287
    0
    16
    WV
    You chopped off my sentence and added a period where there was none for what reason? I posted every step I took for others who were having the issue I was. Figured I'd throw that bit in since I didn't want to leave out anything I had done, sorry that you focused in on that. Sure it doesn't affect anything, but it didn't hurt anything to include either.
     
  12. Yes, it does because it's needless. Running a game as an administrator has nothing to do with it's frame rate. Your sentence is structured in a manner to make it seam as if it does have an effect. So yes, there was a reason for me focusing on only half of your sentence.
     
  13. gold lightning

    gold lightning

    Member
    493
    0
    16
    I just have to say this about people having issues with Optimus graphics. I don't have SLW so I can't confirm or deny this being a fix for it, but as far as the best fix for Generations goes, I haven't seen it mentioned here.

    The best fix is to use the nVidia Control Panel to set up a profile for the game and config tool executables. From there you can set a desired GPU and this usually force-feeds that GPU to the programs. I know 100% that this works for Generations and I'm assuming it would work for SLW as well.
     
  14. Azookara

    Azookara

    take it from me, little buddy Member
    2,997
    30
    28
    Meowth's party
    hoboagogo?
    [youtube]http://www.youtube.com/watch?v=f1UWoXLCSX0[/youtube]

    New (???) glitch in SLW's PC version. I can confirm it because it happened to me at three different times last night, and I don't remember ever running into this problem on the Wii U version.

    Also yes this port is messy from what I can tell. The menus look miserable.
     
  15. Elliot Gindi

    Elliot Gindi

    Member
    92
    0
    0
    New York
    Brawl Minus
    I wish the HUD wasn't so low res when I raise my resolution.

    And how is it that I downsampled from 3200x1800 but there's still jaggies galore?
     
  16. GeneHF

    GeneHF

    SEGA-ier than you'll potentially ever be. Site Staff
    8,387
    0
    16
    Scenic Studiopolis
    Complete Global Conquest
    That's also doable on the Wii U version. I've had it happen quite a few times.
     
  17. ICEknight

    ICEknight

    Researcher Researcher
    They probably removed frame skipping to achieve this:
    [​IMG]
    So remember: It's not a bug, it's a feature! :v:
     
  18. Jimmy Hedgehog

    Jimmy Hedgehog

    Member
    1,728
    8
    18
    England - Slough
    Getting the motivation to continue old projects
    I've had no issues with this port whatsoever and playing it on a control without any touch requirements has been good. I personally feel it's a good port, and it runs perfectly fine, so it's unfortunate that some have had issues.
     
  19. Elston87

    Elston87

    I'm raiding witches. Member
    41
    0
    0
    Played the first two worlds on the PC port so far; the game seems really optimized. My GTX 745 isn't even sweating despite its small cooler.

    As for the game itself, boy there's a bunch of things to knack on. You can't sidestep, which this game practically NEEDS it; Desert Ruins Zone 2 comes to mind. Zone 4 was also terrible, which I lost a lot of lives on because I was outrunning the screen. The parkour moves are also wonky, so I feel. The boss fights seriously kill any flow the levels had, though...

    Visually the game looks good, themes and such, but yet it seems it's always one step forward and three steps back for the Sonic games.
     
  20. TimmiT

    TimmiT

    ¯\_(ツ)_/¯ Member
    This is usually how it works with games that don't immediately recognize the Nvidia GPU, however it doesn't (or didn't) work with Generations. Still, after seeing people mention this and me not being able to play it with the Nvidia GPU right now cause of having issues faking a second monitor to extend the display to, I tried looking into why it didn't work for me. So this is what I did:

    I removed the GraphicsConfig cfg file from the Generations folder that I had messed with to get the game working right for me so the Configuration tool could make a new one. Surprisingly, it recognized the Nvidia GPU and I selected it. However, Generations still gave me an error because of the wrong GPU being assigned or something. When I looked at the cfg file it was pretty much the same to the way I had edited to, with it listing my Nvidia GPU.

    Then I deleted the cfg file again and tried starting the Configuration Tool with the Intel GPU. This time it made the cfg file with it listing the Intel GPU instead. Then I started the Configuration Tool again but with the Nvidia GPU, which it recognized and I saved. This time the cfg file kept listing the Intel GPU, however, the Nvidia Control Panel had forced both the Configuration Tool and Generations exe to use the Nvidia GPU. Then I tried starting the game, and this time it started without saying the wrong GPU was assigned and it was using the Nvidia GPU.

    So I guess SEGA/Devil's Details actually did sort of fix the Optimus issue. They seemingly just did it while letting the cfg file think that the Intel GPU is being used to get past the wrong GPU being assigned error. Now the question is when Sega/Sonic Team will fix it for Lost World, cause right now forcing the game to use the Nvidia GPU through the Control Panel doesn't work. It's also different from Generations as in that there's no separate configuration tool or config cfg file.