don't click here

THE SonED2 thread

Discussion in 'Engineering & Reverse Engineering' started by Stealth, Sep 2, 2006.

  1. Guys, anyone know how to successfully convert levels to E02?

    Mine always end up crashing E02 when loading.
     
  2. Stealth

    Stealth

    Tech Member
    594
    30
    18
    Sonic Mania, HCGE, Sonic Megamix, SonED2, [...]
    CTRL+Z apparently doesn't disallow deletion of Block 000 (Not Block001, may be the last one you caught before the crash) in the current release. The simpler way to remove all tiles, though, is to delete the tile file, and it will open blank

    According to the date of this post, you must be using Demo 6. There are two things that could be going wrong:

    1 - If you copied the SonED2 output over Test Zone, you have too few display planes. Test Zone tries to spawn 7, and a standard level would normally have only 3 or 4 (SonED2 outputs 4). Try writing over SIZ, or in the new Demo 7, GHZ

    2 - SonED2 outputs tile planes with no scroll properties, because there is nowhere to get them from. You will have to start in editor mode before gameplay begins (press E during the titlecard, or use -warp and -editor, or the launcher's warp and editor options), switch to the background planes (including the blank one) and set them to "relative" type, and set their X and Y scrolling to 0/64. Leave them this way until you're ready to define the actual scroll properties, this is so the game doesn't try to display beyond the plane boundaries. Also, SonED2 outputs in this way-
    0 - B Low
    1 - A Low
    2 - B High
    3 - A High
    Though, the current init script included with Project Mettrix uses the planes in this way:
    0 - B Low (Background)
    1 - B High (Secondary Background)
    2 - A Low (Foreground)
    3 - A High (Superforeground)
    Use the editor's Ctrl+C, Ctrl+D, Ctrl+A, and Ctrl+P options to copy A low (plane 1), Delete A low (plane 1), Add a new plane below A High (now at Index 2, creates a new Plane 2), and paste A low to the new plane 2. This will put the planes in the correct order. Or, alternatively, edit the level init script to use the planes in the same order as they are output from SonED2

    E02 relies on proper script and data setup, so make sure you know what you're changing and what it will expect to find when you modify anything. The current documentation should still be sufficent as far as that goes
     
  3. muteKi

    muteKi

    Fuck it Member
    7,696
    65
    28
    Good to know you're still supporting this.
     
  4. Varion Icaria

    Varion Icaria

    He's waiting.... Tech Member
    1,019
    11
    18
    S4: Cybernetic Outbreak
    Edit: Nevermind
     
  5. jman2050

    jman2050

    Teh Sonik Haker Tech Member
    634
    4
    18
    This isn't rocket science people.
     
  6. Sort of major problem with SonED 2 that I'm having. This time I was able to pinpoint it and not save (set files to read only). I felt I needed to bump this because it's not a minor question, and it didn't deserve it's own thread, anyway!
    Edit: So yeah, sorry for the bump :x



    I'm trying to make ehz1 load its own palette for the underwater palette, as the tile editor has the palette switcher. The two files are identical (ARZ.sep and EHZ.sep) when it comes to the values, but only the files themselves have been changed. So 3 palette lines, etc etc.



    It loads fine, however, SonED2 rapes the collision indexes. Image below:
    [​IMG]

    If I get rid of the 3rd palette line in the project, it loads everything correctly, and saves everything, however I need that palette line. If anyone wants I can paste an image of the two project files side by side.
     
  7. Code (Text):
    1. Palettes-
    2.  
    3.  Number of files: 2
    Are you sure you changed this to 3?
     
  8. Yes, I changed that to 3.

    Edit: And if you try saving like that it gives you a million errors saying bad collision detected and then crashes <__<
     
  9. SMTP

    SMTP

    Tech Member
    It looks just like:

    Code (Text):
    1. Type: 2
    2.  
    3. Zone ID:    0
    4. Act ID:  0
    5.  
    6. Object Def: objdef\s2obj
    7.  
    8. 8x8 Tiles:   ..\art\kozinskix095C24 - EHZ and HTZ.bin
    9.  
    10. 16x16 Tiles:   ..\mappings\16x16x094E74 - EHZ.bin
    11.  
    12. 128x128 Tiles: ..\mappings\128x128x099D34 - EHZ and HTZ.bin
    13.  
    14. Level Layout:  ..\level\layoutx045AC4 - EHZ act 1.bin
    15.  
    16. Objects:       ..\level\spritesx0E684A - EHZ act 1.bin
    17. Rings:       ..\level\ringsx0E4344 - EHZ act 1.bin
    18. Misc:         NONE
    19.  
    20. Palettes-
    21.  
    22.  Number of files: 3
    23.  
    24.   Palette 1-
    25.  
    26.    Start index:     0
    27.    Number of entries: 16
    28.    File:              ..\art\palettes\bgndpal.bin
    29.  
    30.   Palette 2-
    31.  
    32.    Start index:    16
    33.    Number of entries: 48
    34.    File:              ..\art\palettesx002A22 - EHZ palette.bin
    35.  
    36.   Palette 3-
    37.  
    38.    Start index:    64
    39.    Number of entries: 64
    40.    File:              ..\art\ehzw.bin
    41.  
    42. Angle Array:             ..\collisionx042D50 - Curve and resistance mapping.bin
    43. Collision Array:         ..\collisionx042E50 - Collision array 1.bin
    44. Rotated Collision Array: ..\collisionx043E50 - Collision array 2.bin
    45.  
    46. Collision Index 1: ..\collisionx044E50 - EHZ and HTZ primary 16x16 collision index.bin
    47. Collision Index 2: ..\collisionx044F40 - EHZ and HTZ secondary 16x16 collision index.bin
    48.  
    49. -EOF-
    Correct? (bar the different path/filenames of course)

    (Ofcourse, SonED2 has NEVER loaded collision at all into the editor when I use it... (or doesnt display it for some odd reason))
     
  10. x64

    x64

    clicked the [x] button Misfit
    92
    1
    0
    Vernal Equinox
    I'm working on your mom.
    [​IMG]
     
  11. Stealth

    Stealth

    Tech Member
    594
    30
    18
    Sonic Mania, HCGE, Sonic Megamix, SonED2, [...]
    It's been brought to my attention that there's an error in SonED v1.02 involving level size and the 1, 2, 3, and 4 keys. This is most likely the cause of the previous error I responded to in this thread, but there was nothing reported to lead me to the possibility of those keys being involved, so I assumed it was a Ctrl+Arrows (harder to mistakenly press) issue with Sonic 2 (whose level size is required by an unmodified Sonic 2 level system to stay at a fixed size)

    The keys changed the editor's level layout size settings without correcting the level data aray, in this manner:

    1) x--
    2) x++
    3) y--
    4) y++

    This meant that you could also correct the mistake, but only if you did it before exiting the editor, and only if you knew how to use them. They weren't meant for inclusion, though. It was just some really old code that I apparently forgot to disable. Ctrl+Arrows is (and was) the proper way to manage level layout size

    I've heard that this has caused a few people problems with having accidentally triggered it, so I made a quickfix to prevent you from having to deal with it at all anymore:

    SonED2 v1.03

    That will have to do for now, since I still have several things to sort out before making a proper update

    Sorry for the inconvenience
     
  12. SGR

    SGR

    Give me the gams. Member
    Ah! So that's why the level I've been working on has been seemingly screwing up lately. Thanks Stealth.
     
  13. I'm getting a "Failed initializing DirectDraw.", hit ok, then "DirectDraw init failed." error.

    Yes, I installed the latest version of Direct X. My graphics card is nVidia GeForce 9500 GT, I'm running windows XP, I have the latest drivers for my gfx card....any ideas on why it's doing that and what I can do to fix it?
     
  14. Stealth

    Stealth

    Tech Member
    594
    30
    18
    Sonic Mania, HCGE, Sonic Megamix, SonED2, [...]
    Just out of nowhere? I know you've been using it without problems until now. Did anything at all happen after double-clicking the program icon before the first DirectX error message?

    What did you recently change about your computer? Any one thing could end up being important

    Newer isn't always better. Did you recently "upgrade" DirectX? Try an older version if you can get the thing to install (I've used "DirectX Eradicator" before, but I've never installed 10).. I don't know about 10's compatibility, and Microsoft couldn't follow a standard to save their lives, even if they set it themselves. SonED2 is compiled with a DX7 SDK, and I'm currently using 9.0c

    Is your video card new? If it is, what were you using before?

    Are you running a different version of Windows than before?

    Were you running any other DirectX programs already when you tried to run SonED2?

    What color depth setting are you using? Have you tried others?

    ...have you tried resetting the computer?
     
  15. I can run 3D games fine (Guitar Hero Aerosmith, Rollercoaster tycoon, etc). My nVidia 8600 GS burned out, and I got the 9500 GT card now. Restarting didn't do anything, neither did changing colour depth. I'm running windows SP3 build 2600. The video card is the only thing that's been changed...But the card is DX9/DX10 compatible so I don't know why it would show that error.


    Edit:

    DXDIAG shows no problems, and all tests pass.
     
  16. Stealth

    Stealth

    Tech Member
    594
    30
    18
    Sonic Mania, HCGE, Sonic Megamix, SonED2, [...]
    That's the problem with your criteria- the stuff you're running is new, and the "diagnostic" program you're running was made by Microsoft themselves and targetted to diagnose only certain issues with the newest version and features, which is all they care about. What I was trying to say was that it's not impossible that they broke backward-compatibility. SonED2 is compiled with the DirectX7 SDK, and even that's only because anything lower wasn't readily available; it doesn't NEED DX7

    I really don't have a good idea of what's happening, at the moment. If all you changed was your video card, it must be something about that card's driver. I know from personal experience that it works fine in XP, and you say it was working with DX10 previously.. that's really all it could be. There must be something about the driver or the installation that isn't playing nice with DirectX when DX7 calls are made, or something. Maybe try uninstalling and reinstalling the driver, updating it, downgrading it.. I don't know

    I'll try thinking about it, but if messing with the driver doesn't help, I really don't know what to do. It works with so many other things, and the issue here is coming when brand-new video hardware is introduced, and when they build that stuff they barely even care if it works with stuff that was released within the last week or so, anyway, as long as you just keep buying new games, OS, and hardware every-other-day

    If anybody else has the same video card and can confirm whether or not they can run SonED2, or E02 (try and run a copy of that and see if it does work for some reason), along with providing OS, DirectX, and other system information, that would be great
     
  17. Shoemanbundy

    Shoemanbundy

    Researcher
    1,083
    17
    18
    Chicago, Illinois
    selling shoes
    I had the exact same problem not too long ago after my pc suddenly was rebooting either on its own or whenever I was trying to view videos on youtube. For some reason the saturn emulator SSF also would never open but just immediately close. I have no idea how all of this worked out together to prevent me from doing anything, but I eventually had to just give up and reformat.

    Have you been to any sites recently that may have given you a virus? My situation was sort of weird and I don't know the specifics. My brother was browsing snesorama's forums when he said that suddenly some pop-up appeared trying to install something. I didn't see it myself but it was ever since then that these issues slowly started cropping up.

    I don' t know if this helps any, but if I were you I'd probably go with a reformat and see what happens. If it's like what I had you'll just spend forever trying to get virus programs but none find anything and you'll have no idea where else to turn to.
     
  18. muteKi

    muteKi

    Fuck it Member
    7,696
    65
    28
    Vista, DX10, Intel 945 (mobile) integrated chip. I just checked it a minute ago and ran just fine.
     
  19. Seems my problem is steaming very deep. Windows is crippled. Looks like I'll have to revert to a backup or format altogether.
     
  20. SR212787

    SR212787

    Member
    80
    0
    0
    Gallifrey, TN
    Sonic 2
    Where do I find build.bat. I have looked everywhere. Sorry if this is a dumb question, or if it upsets anyone.

    EDIT: NM I found it... I still don't know how to use it though.