I think I may have a dodgy graphics problem

Discussion in 'Technical Discussion' started by MarzSyndrome, Jul 16, 2014.

  1. MarzSyndrome

    MarzSyndrome

    Everything is going to the beat. Member
    Usually, when I set up emulators on Windows I opt to go for fullscreen mode, with the resolution matching my desktop's (1920x1080x32) and all filtering disabled so I get that nice, clean, pixellated sharpness.

    Unfortunately, it seems certain emulators do something or other with their upscaling function which means I get end results like this (click on the picture on the new page to expand it):
    [​IMG]

    This was captured in Kega Fusion 3.64. Look around the bottom of the screen. You'll notice tons of misplaced pixels on the edges and whatnot. Certain other parts of the screen have this issue as well if you look closely enough.

    This only seems to happen if I upscale unfiltered graphics to my desktop resolution (if bilinear filtering is enabled the odd pixels disappear, but I'd rather not have everything looking blurry or "soft"). Although if I open up KF's INI file and set "EnhancedGFXOpt=1", it seems to improve the picture, but not completely:
    [​IMG]

    Kega Fusion seems to be the worst offender of this I've come across so far. The problem exists in a select few emulators as well, such as RetroArch - which really bugs me off because I don't fancy its own bilinearing efforts either, and the odd pixels issue even creeps into shader filters. If I enable Integer Scaling in RA it eliminates them, but then it tends to leave the main screen too small for my liking, with too much black space surrounding it.

    The fact this graphical glitch only seems to happen in certain emulators and not others has left me confused. I'm not really able to narrow it down to the type of driver being used (Direct3D or OpenGL) or the monitor I'm using (ASUS PB238Q), or the type of display hardware installed (integrated graphics), though my heart seems to be thinking the last one. Will I need to move on to an AMD or nVidia card in this case?


    Anyhoo, my specs:

    ASUS PH877-V LE Motherboard
    Intel Core i5-2310 @ 2.90GHz
    8GB RAM
    Intel HD Graphics 2000
    Realtek HD Audio
    Windows 7
     
  2. winterhell

    winterhell

    Member
    1,160
    0
    16
    It looks like there is bilinear filtering on the whole image after it has been produced big pixelated( as opposed to 320x240 being bilinear stretched 400%)

    In Fusion you set the fullscreen resolution to 1440x1080, correct? Do Intel drivers have an option for "no scale"? On nvidia you can choose the scaling mode between no scale, keep aspect ratio and full stretch.
     
  3. MarzSyndrome

    MarzSyndrome

    Everything is going to the beat. Member
    "Produced big pixelated"? Not sure if I quite get you. :S

    No, like I said I set fullscreen resolution to 1920x1080, matching my desktop. I just have "Fixed Aspect (Fit)" enabled in the options to get the proper aspect ratio (for the record, it's no better when stretched to fill the whole screen - still misplaced pixels).

    I prefer to not use different resolutions as the long wait time for the monitor to spring back to life after each resolution change is aggravating enough.
     
  4. winterhell

    winterhell

    Member
    1,160
    0
    16
    I prefer to not use different resolutions as the long wait time for the monitor to spring back to life after each resolution change is aggravating enough.
    [/quote]

    Depending on if Intel supports this or not, you can enable GPU resolution scaling by one of the 3 types I mentioned above. That way the monitor always receives the same resolution and doesn't have to do any scaling. As a bonus often the GPU scaling is of a higher quality than monitor's.
     
  5. MarzSyndrome

    MarzSyndrome

    Everything is going to the beat. Member
    Well, here's what a typical Intel Options window looks like on my end.

    [​IMG][​IMG]

    Under the native resolution, those two scaling options are the only ones available. If I'm on a lower non-native resolution on the other hand, it unlocks a couple more options relating to aspect ratio (for instance, whether to stretch a 640x480 display or keep it at its original aspect).

    Other than this, I'm not quite sure what else would relate to GPU scaling. Do integrated graphics have a GPU even? (I'm probably at risk of sounding like a moron here.)
     
  6. muteKi

    muteKi

    Fuck it Member
    7,573
    2
    18
    Having trouble IDing which parts of the image are the result of jpeg artifacting here; can you go with PNG screenshots instead?
     
  7. It's almost without a doubt the Intel graphics; I've got a similar system to yours aside from the GPU (2500k instead of a 2310, P8Z68-V instead P8H77-V LE for the motherboard, GTX 570 for the GPU instead of the CPU's built in HD 2000) and I don't get any of these errors.
     
  8. MarzSyndrome

    MarzSyndrome

    Everything is going to the beat. Member
    They are PNGs. Are you clicking on the picture again after it's loaded on the PostImage page?

    Anyway, after much playing around, I appear to have found a workaround of sorts.

    While it's not a direct solution to the output/scaling problem, as it transpires it's okay for me to use bilinear filtering provided I combine it with a shader designed to maintain pixel sharpness.

    With Kega Fusion I can use Double/DoubleRaw or Quad/QuadRaw from the plugins pack to eliminate blurriness and pixel misplacement, and some of the included shaders in the Windows archives of RetroArch for a similar result (such as Stock, Sharp Bilinear or Quilez). (With the latter though, I need to be wary about using a scale factor of 5x - while it makes the screen look just as crisp as it did with bilinearing disabled, certain cores take a significant performance hit with 5x, and may possibly result in a small reduction of FPS in all other cores.)

    Or with Mednafen, there's a built-in setting to apply a sharper version of bilinear without the need for an external shader.
     
  9. Chibisteven

    Chibisteven

    Member
    1,293
    7
    18
    US
    Saw the problem, actually. It's your graphics card or onboard graphics. Fusion doesn't display images like that. Did you try updating your drivers? Sometimes it's a driver issue (hopefully), other times it's crappy hardware.