Hard Drive Issues... ? Maybe...

Discussion in 'Technical Discussion' started by saxman, Apr 26, 2011.

  1. saxman

    saxman

    Oldbie Tech Member
    I'm working on a computer that is acting rather strange. Here's a run-down of the basic symptoms I ran into:

    - Sometimes Windows XP will take a long time booting up (and sometimes will hang during this process)
    - Sometimes Windows XP will take a long time to shut down (and sometimes will hang here too)
    - While attempting to defrag, it stayed at 17% for a good 20 minutes before continuing
    - Compressing files on the disk using Disk Cleanup took a good 30 or 40 minutes

    I've worked with this computer before, and I can assure you that none of these things are normal. The computer isn't entirely unstable. When succeeding in booting, it appears otherwise to work flawlessly when using it. I am also told that the blue screen occured at one point, although it has never happened with me, so I don't know what it said.

    First I thought "hard disk must be going bye-bye". However, I can't seem to prove this one way or the other. I'm on the fence right now.

    I also considered configuration or driver issues. I tried things out in Safe Mode, but the problems persist there.

    I used a utility to test the RAM in the machine, and everything was okay there.

    I went back to my hard disk theory as that makes the most sense to me and is the most likely scenario. I attempted to backup the hard disk using Clonezilla. I have used it numerous times in the past to backup the drive. It did something funny when it was testing the drive that it has never done before. I took some pictures as I couldn't read the text that was quickly scrolling up the screen repeatedly:

    <a href="http://i625.photobucket.com/albums/tt338/saxman727/_CIMG4732.png" target="_blank">http://i625.photobucket.com/albums/tt338/s...7/_CIMG4732.png</a>
    <a href="http://i625.photobucket.com/albums/tt338/saxman727/_CIMG4728.png" target="_blank">http://i625.photobucket.com/albums/tt338/s...7/_CIMG4728.png</a>
    <a href="http://i625.photobucket.com/albums/tt338/saxman727/_CIMG4726.png" target="_blank">http://i625.photobucket.com/albums/tt338/s...7/_CIMG4726.png</a>

    It appears that it's having a hard time reading the disk...? However, after about 5 minutes of this, it finally brings me to the menu where I can select the type of backup operation I want to perform. The backup is successful with no bad sectors or other errors ever detected.

    So... now I'm stumped. I don't know if this drive is actually bad or not. The symptoms I would expect to be there aren't there. Could there be something else going on? Any ideas would be much appreciated!



    EDIT: It may be worth noting that I restarted the machine several times during testing, and at one point it didn't detect the keyboard, and one other time it didn't even detect the hard drive. In both cases though, the machine was restarted rather than shutdown. I know that sometimes freak things like that can happen if the RAM doesn't have a chance to clear out before booting again. Still, I thought these things were rather odd. They happened once each.
     
  2. Vangar

    Vangar

    Member
    Could be a fried motherboard?
     
  3. HighFrictionZone

    HighFrictionZone

    Hi. Member
    855
    0
    16
    Katy, Texas
    Nothing
    My initial idea is that you might have a program which runs at startup and shutdown which is causing this (For example, lately Steam has been causing my computer to take forever to shutdown - manually killing the steam process and then shutting down results in normal shutdown times).

    However, you have indicated that the problem persists even in safe mode. Additionally, you are noticing issues using clonezilla.

    Quick google searching of the legible text from the images you took leads me to think it could potentially be an issue with the drive controller on your hard disk/motherboard. It is, admittedly, kind of difficult to determine if this is the case. If possible, I'd try and put a similar hard disk in the computer and see if, for example, clonezilla still produces errors while detecting the drive. If it does not, the problem could be your hard disk and you should perhaps move over to a new disk. If it does, it could be a problem with the controller on your motherboard and could require that component or the entire motherboard to be replaced.

    Of course, this is just a bit of educated guessing. ("SCIENCE!") - but it is possible that the drive itself is fine and the part that communicates from the drive to the OS is not.

    Other possible (but less likely) errors (in descending order of likelyhood):
    *The drive actually is failing. Do a full SMART test and see if it reports errors
    *The motherboard has decided to start mis-detect the drive as a different speed/whatever. Go back into BIOS configuration and make sure the drive is configured correctly
    *Windows update accidentally borked your chipset driver. Check with your computer manufacturer to make sure your drivers are up to date?


    I guess it's also possible that the connection isn't seated properly? Go make sure everything is connected correctly and securely, make sure the drive is correctly detected in the BIOS and doesn't report errors in self-test, make sure windows has the latest drivers for your drive controller, make sure that if it is a SATA drive that it's actually plugged in like a SATA drive and not using a SATA->IDE converter or some nonsense like that.
    If none of that affects it in any way, I would probably say that one of the intermediary components is not functioning.
    Try the disk in another box. If problem persists, it's the disk controller (which is built into the hard disk) - move the data to a new disk and replace. If the problem does not persist, either the cable or the part where the cable plugs in are at fault. The cable is easy to replace. The connector is not. You could be looking at a new motherboard.

    But of course, that's just what I'm guessing at. If you can provide any more information as to troubleshooting steps you've taken or other errors you encounter, that could help.
     
  4. RamiroR

    RamiroR

    Member
    355
    0
    16
    Check the BIOS for voltage levels and write them down. It is what happened to me.. so it MIGHT be that.