don't click here

Sonic 1 (2013 - iOS/Android) Post-Release Bugs/Fixes/Suggestions

Discussion in 'General Sonic Discussion' started by Skaarg, May 17, 2013.

  1. TheOcelot


    Scooty Puff Jr sucks! Member

    Since the recent update I've noticed that the soundtest in the level select no longer works. When I press the button on the soundtest to play a music track it doesn't play the music and automatically jumps 10 places forward (from 00 to 10). If I then press the soundtest button again it jumps 10 places backwards (from 10 back to 00) and there is still no sound. If you keep pressing the soundtest button it keeps jumping 10 places forward and then 10 places back again respectively.

    I have an android galaxy S4.

    Sonic 2's soundtest still works fine.
  2. OS version would be helpful with debugging. :v:
  3. TheKazeblade


    "Our Life is More than a Side-Effect" Member
    Someone brought it up on Taxman's twitter, he's aware of it and said he worked out the issue :)
  4. Aerosol


    Not here. Moderator
    Not where I want to be.
    Sonic (?): Coming summer of 2055...?
    The arrow seems to be acting like the 'A' button in the level select for me. I can't play any sound test songs, it skips 16 tracks ahead instead. This might be related to my inability to perform the "activate a 7th chaos emerald in a save file" trick as well.
  5. TheKazeblade


    "Our Life is More than a Side-Effect" Member
    It is, Taxman said he's working on it.
  6. TheOcelot


    Scooty Puff Jr sucks! Member
    Thanks for the heads up.

    Yeah, Taxman said:

    I then tweeted Taxman and he responded:

  7. Aerosol


    Not here. Moderator
    Not where I want to be.
    Sonic (?): Coming summer of 2055...?
    Oh good so my new phone isn't broken in some weird way then. Thanks.
  8. My question is related to Android emulation in a Core I5 with 8GB of RAM. I just can't play Sonic 1 neither in Genymotion, Bluestacks.

    The first thing I noticed is that Sonic 1 force closes right after selecting a save slot, or even before reaching that screen. It happens in the following VMs:

    - (Bluestacks 8.11.3116 - Android 4.0.4 - ICS)
    - (Bluestacks - Android 4.4.2 - KitKat)
    - (Genymotion 2.4.0 - Samsung Galaxy Note 3 - Android 4.4.4 - KitKat)
    - (Genymotion 2.4.0 - Samsung Galaxy Note 3 - Android 4.3 - JellyBeam)

    The second situation is where the game does start, but it lags a lot, even not using much memory or CPU processing. I managed to run the game in Genymotion and Andyroid, both using JellyBeam:

    - (Genymotion 2.4.0 - Samsung Galaxy S4 - Android 4.2.2 - JellyBeam)
    - (Andyroid - Android 4.2.2 - JellyBeam)

    EDIT: confirmed older apk 2.0.4 runs fine in all systems which newer is not running. It seems like the newer versions doesn't like Virtual Machines or something. Though I've paid for the apps when I had a a Xperia Mini Pro, I had to look for the older apks to confirm newer's bug.

    EDIT2: Genymotion will play fine if you lower the DPI. Default VM DPI is 480, lowering it to 240dpi should make it a lot faster. Graphic GPU is recommended, but will run fine in a Intel HD 4000. Android versions 4.2.2 is required since the newest Sonic 1 and 2 apks aren't working in other versions (at least in VMs)
  9. RibShark


    I haven't seen this bug reported before, but on my HTC One M7, when Sonic is standing in shallow water so only half of him is submerged and then jumps, he gets catapaulted towards the top of the screen.
  10. Mastered Realm

    Mastered Realm

    A green crystal Member
    Xperia Z2: Knuckles has no pushing sprites in Sonic 1 (he just walks into an object or wall).
  11. The Taxman

    The Taxman

    Tech Member
    Retro Engine & Related Projects
    Just checked and it looks fine to me. Knuckles' pushing animation is styled differently to Sonic and Tails in that he doesn't hold his hand against the wall.
  12. Mastered Realm

    Mastered Realm

    A green crystal Member
    You're right o.o omg

    I'm feeling really retarded but it does look strange. I guess they never gave him pushing sprites because on most cutscenes on Sonic 3 and Knuckles he just walks into them and they break.
  13. ICEknight


    Researcher Researcher
    He just tries to break the walls...
  14. Mastered Realm

    Mastered Realm

    A green crystal Member
    Yeah but his feet move, it's just the walking animation. Anyway, it's has been like this ingame, case closed ;p.
  15. Mystical Ninja

    Mystical Ninja

    For old time's sake. Oldbie
    New Castle, Delaware
    Nothing that concerns this place in the least.
    So, I got the Android version a few days ago, and I've discovered a bug in the level select menu, where you're unable to play any sounds in the sound test, thus making any codes impossible to enter.
  16. Zycor


    Unlike Sonic, I don't chuckle. Member
    Beats me.
    Came to report the same thing Mystical Ninja reported. Really weird. Pressing play increments and or decrements by 10 instead of playing the track. Making debug and emeralds codes impossible.

    Or is it A due to hex?
  17. TheOcelot


    Scooty Puff Jr sucks! Member
    Sonic 1 received a new update; 2.1.2 on the App store on March 2nd which has fixed the sound-test issue for iOS devices.

    There's not been an update yet to fix the issue for android.
  18. JcFerggy


    Do you want to taco 'bout it? Member
    Nova Scotia, Canada
    GoldenEye: Source, Other Stuff
    I know the chances of an update at this point are slim to none, but I figured I may as well bump the topic to say the jumping out of water glitch is still present in the current Android version.


    Basically when standing in shallow water when the wave is at its highest, jumping out of the water gives you a ridiculous jump height.
  19. MotorRoach


    Can confirm that glitch still exists. Pretty hard to ignore it, actually.
  20. IrnBru


    I bought both of these (Sonic 1 & 2, I have CD on 360) last week from the play store and hate the virtual pads. It runs like a dream on my android phone and it's not even that powerful. I'm thinking about installing android on a partition on my laptop and loading it from there to use the keyboard or a good usb pad on a big screen. Would this work?

    Emulating them is totally out of the question, I've tried syncing my phone with bluestacks and running the game, I've tried side loading the .apk file into bluestacks and keep getting crashes.