SFC won't show anything

Discussion in 'Technical Discussion' started by 아힝흥행, Mar 23, 2012.

  1. 아힝흥행

    아힝흥행

    Member
    96
    0
    0
    Korea/Canada
    A fan movie that is about 10 minute
    So, I just dusted off my SFC and tried to play turtles in time... I realized I didn't have the component cables, so I went out and bought a Gamecube Multi cable thingy that has the S-Video.

    My power supply is 220v oddly enough, I couldn't find the original supply. But, I remember that not being a problem.

    Turn it on, Nothing appears, I don't think its the Cartridge. I honestly don't know what is wrong.
     
  2. Chibisteven

    Chibisteven

    Member
    1,311
    18
    18
    US
    The SFC doesn't have component cables, they're composite cables. Just sounds like a crappy cable to me. As the design could be causing inpendence issues with other consoles attached to it or if I'm reading this wrong... It could just be the cable is bad and not passing on a signel. I can't recall if SFC had S-Video output to begin with... Someone who knows more about the SFC could help you with that.

    Try cleaning the cartridge slot and the game first and checking the seating of the slot (could be worn, too).
     
  3. 아힝흥행

    아힝흥행

    Member
    96
    0
    0
    Korea/Canada
    A fan movie that is about 10 minute
    Actually I was just about to edit that to Composite cables. oops :v: Well, I asked Kiddo and he said "Gamecube S-Video cables should work fine with the SFC" so yes, the S-Video for SFC exists :v: