Linux font woes

Discussion in 'Technical Discussion' started by Andlabs, Oct 3, 2012.

  1. Andlabs

    Andlabs

    「いっきまーす」 Wiki Sysop
    2,175
    0
    0
    Writing my own MD/Genesis sound driver :D
    I have the same problem with Linux font rendering on two separat eoccasions: afte upgrading from Kubuntu 12.04 to Kubutnu 12.10 beta, andafter editing ~/.fonts.conf in Linux Mint KDE Maya. The Ubuntu font no longer renders properly: it renders with elongated letters and differnet font height, and monospace fonts are significantly blurier (for instance, the t is VERY blurry. The Ubuntu font width problem seems to get better if I set hintstyle to hintnone, but I still don't feel comfortable; I want the settings eaxactly the way they were before, just with the changes I made to ~/.fonts.conf (having serif and sans-serif be DejaVu instead of Droid). Undoing all my changes to this file and removing the file entirely do not fix the problem.

    Here is an example from Mint:
    What it used to look like: http://I.imgur.com/wXa9R.png
    What it looks like now: http://I.imgur.com/YsT1m.png
    What it looks like now with antialiasing turned off: http://I.imgur.com/LHYsL.png
    Full screen: http://I.imgur.com/s62el.png

    Current ~/.fonts.conf:
    Code (Text):
    1. <?xml version="1.0"?><!DOCTYPE fontconfig SYSTEM "fonts.dtd">
    2. <fontconfig>
    3.  <match target="font">
    4.   <edit mode="assign" name="rgba">
    5.    <const>none</const>
    6.   </edit>
    7.  </match>
    8.  <match target="font">
    9.   <edit mode="assign" name="hinting">
    10.    <bool>true</bool>
    11.   </edit>
    12.  </match>
    13.  <match target="font">
    14.   <edit mode="assign" name="hintstyle">
    15.    <const>hintnone</const>
    16.   </edit>
    17.  </match>
    18.  <match target="font">
    19.   <edit mode="assign" name="antialias">
    20.    <bool>true</bool>
    21.   </edit>
    22.  </match>
    23.  <alias>
    24.   <family>serif</family>
    25.   <prefer><family>DejaVu Serif</family></prefer>
    26.  </alias>
    27.  <alias>
    28.   <family>sans</family>
    29.   <prefer><family>DejaVu Sans</family></prefer>
    30.  </alias>
    31. </fontconfig>

    How do I fix it? Thanks.
     
  2. kuroshi

    kuroshi

    Member
    32
    0
    0
    Riverside, CA, US
    foobar2000 components, many related to emulation; Cog, an audio player for Mac OS X
    Try adding:
    <match target="font">
    <edit name="autohint" mode="assign">
    <bool>false</bool>
    </edit>
    </match>

    And whether or not that has any effect, try setting hintstyle to hintslight, hintmedium, or hintfull. hintslight is recommended if you're going to use the autohint true option.
     
  3. Andlabs

    Andlabs

    「いっきまーす」 Wiki Sysop
    2,175
    0
    0
    Writing my own MD/Genesis sound driver :D
    Thanks, but hintmedium produces wonky character widths (an elongated t in the Ubuntu font, for instance) and adding autohint false did not fix the issues.