Is this possible?

Discussion in 'Engineering & Reverse Engineering' started by DDRKhat, Feb 13, 2004.

Thread Status:
Not open for further replies.
  1. DDRKhat

    DDRKhat

    Keep on runnin' to the finish! Member
    Im doing pretty well on the start of my hack, it starts on Green Hill Zone. but im having some problems.

    1) You cant go around the loop (as you can see in the attachment)
    2) Moving platforms are glitched up
    3) Those stones arn't there (the ones that slow you down apparently)
    4) those gliffs that give way arn't there either.


    Would it be possible to get the loop to work correctly? I've tried putting in the loop object but you still run strait through it
     

    Attached Files:

    • ghz.gif
      ghz.gif
      File size:
      35.7 KB
      Views:
      2
  2. DDRKhat

    DDRKhat

    Keep on runnin' to the finish! Member
    Heres the glitched up platforms:

    Also that starpost doesn't work.
     

    Attached Files:

    • ghz.gif
      ghz.gif
      File size:
      37.7 KB
      Views:
      2
  3. DDRKhat

    DDRKhat

    Keep on runnin' to the finish! Member
    Missing Platforms:
     

    Attached Files:

    • ghz.gif
      ghz.gif
      File size:
      31.4 KB
      Views:
      1
  4. DDRKhat

    DDRKhat

    Keep on runnin' to the finish! Member
    And last but not least. the missing stones:
     

    Attached Files:

    • ghz.gif
      ghz.gif
      File size:
      28.4 KB
      Views:
      1
  5. Perhaps with the loop, you need to place an object of some sort that tells the game what to do.
     
  6. Fiz

    Fiz

    FACKIN' BIG PENIS Oldbie
    1,985
    0
    0
    PENIS
    Yeah, like the line of rings from Sonic 2 that indicates when something is going to happen. I don't think the line of rings is in Sonic 1 though. I don't know much anything about problems of this nature. Wish I could help, Foamzo.
     
  7. Trigahd

    Trigahd

    I am your gahd!! Member
    1,523
    0
    0
    Somewhere in the skies
    Nothing worth mentioning
    in Sonic 2 you need two objects to tell sonic to do the loop. I'm not sure how it is with Sonic 1, but I'll look into it and try to help.
     
  8. Quickman

    Quickman

    Tech Member
    5,584
    0
    16
    :x
    omg porjcet
    The glitched platform is simply missing graphics which aren't loaded into the VRAM. Put the relevant graphics on the pattern load cue, and be sure to put them in the right place in VRAM. A quick check of the object and VRAM ought to tell you what's what.
     
  9. DDRKhat

    DDRKhat

    Keep on runnin' to the finish! Member
    Erm, guys, the reason the platform is glitched up is because.. DUN DUN DUNNN! ITS ON SONIC 2!!
     
  10. Trigahd

    Trigahd

    I am your gahd!! Member
    1,523
    0
    0
    Somewhere in the skies
    Nothing worth mentioning
    That might explain why Tails is there.
     
  11. DDRKhat

    DDRKhat

    Keep on runnin' to the finish! Member
    Heh ;)
     
  12. DDRKhat

    DDRKhat

    Keep on runnin' to the finish! Member
    Here is a pic of the loop in the sonic editor btw I've got Tailese as my mouse pointer so you know ;)
     

    Attached Files:

  13. LOst

    LOst

    Tech Member
    4,889
    1
    16
    You know when using debug, you can get an object which looks like 4 rings. Use that to make the loop work. Play Sonic 2 Beta, or Sonic 3 and see what I mean
     
  14. Hivebrain

    Hivebrain

    Administrator
    2,839
    17
    18
    53.4N, 1.5W
    HiveView
    That looks a lot like my hack:

    [​IMG]

    I hope you did everything yourself, and didn't simply copy & paste data from my hack.
     
  15. Hayate

    Hayate

    Tech Member
    :wtf: Are you a six-year-old or what??! :blink:
     
  16. Quickman

    Quickman

    Tech Member
    5,584
    0
    16
    :x
    omg porjcet
    :wtf: How is that relevant??! :blink:
     
  17. Hayate

    Hayate

    Tech Member
    It's not. But who would want Tails as their mouse pointer?

    ... Wait, if that was a mouse pointer, it wouldn't be in the picture. :blink:
     
  18. GerbilSoft

    GerbilSoft

    RickRotate'd. Administrator
    2,894
    24
    18
    USA
    rom-properties
    Unless this person manually copied and pasted the mouse pointer on the image.

    If you don't know what we're talking about, pressing PrintScreen takes a picture of the screen and copies it to the clipboard. (Alt+PrintScreen only takes a picture of the active window.) The PrintScreen command does NOT take a picture of the mouse pointer, so this image would have to be manually edited to include the mouse pointer.
     
  19. Rika Chou

    Rika Chou

    Tech Member
    5,254
    116
    43
    Somehow, I feel that it's probably what he did. I doubt that he knows enough to add all that stuff himself.
     
  20. Quickman

    Quickman

    Tech Member
    5,584
    0
    16
    :x
    omg porjcet
    I think you're right, and the manually pasted Tailese cursor didn't help.
     
Thread Status:
Not open for further replies.