Sonic and Sega Retro Message Board: Chaotix 1207 discussion - Sonic and Sega Retro Message Board

Jump to content

Hey there, Guest!  (Log In · Register) Help
  • 13 Pages +
  • 1
  • 2
  • 3
  • Last ►
    Locked
    Locked Forum

Chaotix 1207 discussion

#1 User is offline drx 

Posted 23 February 2008 - 07:47 PM

  • <Shade> fuck MJ
  • Posts: 2108
  • Joined: 02-March 04
  • Gender:Male
  • Project::rolleyes:
  • Wiki edits:8
...

#2 User is offline Cinossu 

Posted 23 February 2008 - 07:51 PM

  • inverted with love~
  • Posts: 2641
  • Joined: 21-June 04
  • Gender:Male
  • Location:London, UK
  • Project:Sonic the Hedgehog Extended Edition
  • Wiki edits:474
I'll start..

Posted Image
Posted Image

aaaaaaa

#3 User is offline ThunderPX 

Posted 23 February 2008 - 07:53 PM

  • Posts: 1451
  • Joined: 17-May 05
  • Gender:Female
  • Location:The Netherlands
  • Wiki edits:20
Where is Espio? :o

#4 User is offline Logan 

Posted 23 February 2008 - 09:59 PM

  • Posts: 31
  • Joined: 25-March 05
  • Gender:Male
  • Project:Cisco Networking CCNA2
This version Chaotix has an interesting intro. If you can actually get to the meeting with metal sonic before it crashes. Espio will just fall out of the sky and metal sonic will be in the far foreground after staring at you for a few he will charge Espio. However the game will crash before you get to see the rest of this scene. This has only been tested in Fusion however I would assume the crash would happen in other emulators too.

#5 User is offline Shoemanbundy 

Posted 23 February 2008 - 10:02 PM

  • Posts: 811
  • Joined: 01-April 07
  • Gender:Male
  • Location:Chicago, Illinois
  • Project:selling shoes
  • Wiki edits:1
How did you get this working in fusion at all? The earliest build that can even play is 1230 for me. Anyway, if anyone wants to play 1230 onwards without it crashing like Kega, use this:
http://www.zophar.ne...retroDrive5.zip

You can get past that lost Metal Sonic scene and play the rest of the game :thumbsup:

#6 User is offline Franz 

Posted 23 February 2008 - 10:06 PM

  • ALL OF THE LIGHTS
  • Posts: 113
  • Joined: 04-December 06
  • Location:Michigan
  • Wiki edits:3
They sometimes work in kega fusion for me, but normally I have to restart the emulator a lot to make it run.

edit: seriously, can anyone come up with a pattern to why it only boots sometimes in kega?
This post has been edited by Franz: 23 February 2008 - 11:40 PM

#7 User is offline Blackbird 

Posted 24 February 2008 - 12:51 AM

  • Posts: 96
  • Joined: 11-August 05
  • Gender:Male
  • Location:Commieland!
I still haven't got it to run for more than 10 seconds straight on Kega, but that's still enough to work up some differences. This is an image heavy post; however, all the screens are .png. So on with the list of differences:

As we all know, that awesome SEGA screen with the pic from the manual.

There's probably been some bitrot in this, as there's audible "beep" and scratch sounds throughout the music. This could also be a glitch, but I'm not entirely sure.

The title screen track has percussion thrown in, as well as most other tracks, as well as the aformentioned beep sound every ten seconds or so, in different variations depending on the track. Sometimes, those beeps seem like missing bits of sound that should be there, this is especially noticeable in
Amazing Arena. Probably bitrot wrecked these wonderful sound samples. Wonder why they took the percussion out, it sounds pretty nice.

All the Knuckles Ringstar malarkey, as well as Heavy being called Heaby in the title screens.

The backgrounds have scrolling issues, sometimes half the background lags behind, sometimes it doesn't.

Graphics flicker a fuckton, making the few bits of gameplay a hell of a lot harder to look at.

Marina Madness is unplayable, gameplay crashes upon touching the ground.

Training level shows Botanic Base title screen and plays the same music (Door Into Summer) that is found in the title screen.

Introduction level in stage select is vastly different from Introduction in "main" mode, at least from the few scroungable moments of gameplay, and plays the same track that the final does, however, in this beeping, percussion state.

World entrance shows no screen, has no collection minigame, no slider...You just run right through its emptyness and arrive at an NPC SELECT screen ( with the tiles shown in that one above post, in this case only including Heavy, Bomb, Vector, Charmy and a bunch of unselectable question marks), after which you will go to a level select screen, with vastly different names, the only one without a picture is "Amusement Park" or Speed Slider (screens below). However, getting these circumstances require SEVERAL emulator resets. All these weird zone select names are bullshit, however, since the title cards keep the final names. Also, notice how they spell "Atraction" with only one T.

Posted Image

Posted Image

Posted Image

Posted Image

Posted Image

Posted Image


All of the five levels are the same, however.

Two final enemies in Techno Tower (very basic routines, though), along with elevator:

Posted Image

Posted Image
This little green guy moves around for a bit and then stands still, expelling smoke.

Posted Image
This guy will go in a semi-oval motion above you and then leave the screen.

Pause move-around mode is always enabled.

Badnik in Marina Madness, resembling "Blinky" from Sonic 2:

Posted Image

Here's screens of the levels (At least, the best screenshots I can get):

Posted Image
Speed Slider

Posted Image
Botanic Base

Posted Image
Amazing Arena

Posted Image
Marina Madness


Well, this is about as much as I can find today, I'll see if I can get more stuff throughout the week.
Also, half of these screens are from sheer luck, especially the World Entrance ones.

EDIT: Yeah, I messed up on the names. Side-effects of sleepiness. Also, I haven't played Chaotix in AGES, my memory's a bit blurry. I'm pretty sure the orb and motobug were in final Chaotix now that I think about it, but could you get confirmation on the flying fish? And I'm pretty sure it's bitrot, the sound, apart from those missing beeps, has a "loud tape hiss" sound over the music.

If there's anything else wrong, go ahead and tell me, I'll fix it.
This post has been edited by Nabaztag: 24 February 2008 - 01:40 AM

#8 User is offline Cooljerk 

Posted 24 February 2008 - 01:09 AM

  • Powered by Crytek. Maximum Game.
  • Posts: 3237
  • Joined: 06-April 06
  • Gender:Male
  • Wiki edits:9
that's Amazing Arena, not Techno Tower.

#9 User is offline muteKi 

Posted 24 February 2008 - 01:18 AM

  • Fuck it
  • Posts: 7371
  • Joined: 03-March 05
  • Gender:Male
  • Wiki edits:91
I've seen those enemies in the final, too.

#10 User is offline Cooljerk 

Posted 24 February 2008 - 01:22 AM

  • Powered by Crytek. Maximum Game.
  • Posts: 3237
  • Joined: 06-April 06
  • Gender:Male
  • Wiki edits:9

View PostThe 無敵, on Feb 23 2008, 10:18 PM, said:

I've seen those enemies in the final, too.

The orb one goes in MM, doesn't it?

#11 User is offline Quexinos 

Posted 24 February 2008 - 01:23 AM

  • Since 1997
  • Posts: 1672
  • Joined: 24-April 03
  • Gender:Female
  • Wiki edits:11
you know now that you mention bitfot, I kind of remember drx saying some of these prototypes were bitrotted, I don't remember but I think they were the Chaotix ones.

#12 User is offline muteKi 

Posted 24 February 2008 - 01:40 AM

  • Fuck it
  • Posts: 7371
  • Joined: 03-March 05
  • Gender:Male
  • Wiki edits:91

View PostCooljerk, on Feb 24 2008, 01:22 AM, said:

View PostThe 無敵, on Feb 23 2008, 10:18 PM, said:

I've seen those enemies in the final, too.

The orb one goes in MM, doesn't it?


Nope, you can see him in the start of TT1 on the final if you're not in a hurry after taking the elevator.

#13 User is offline drx 

Posted 24 February 2008 - 05:55 AM

  • <Shade> fuck MJ
  • Posts: 2108
  • Joined: 02-March 04
  • Gender:Male
  • Project::rolleyes:
  • Wiki edits:8
It's not bitrot, it's odd hardware that required writing 0x0000 and 0x0400 to the PWM register alternatively all the time at the Sega screen.

#14 User is offline Blackbird 

Posted 24 February 2008 - 11:02 AM

  • Posts: 96
  • Joined: 11-August 05
  • Gender:Male
  • Location:Commieland!
Oh, so it isn't bitrot? Well, that was weird.

Even with Pause move around mode, you can't get past certain bits with Kega, so exploring the levels fully is a definite no until there's a way to fix this (yeah, I tried the byteswapped checksum in 1A0008, jack shit happened).

Big mistake. There is a difference on which act you pick, but in Speed Slider all 5 are the same, and in Amazing Arena all acts after the second don't work. Also, the only way to select Speed Slider is through Stage select, since selecting "AMUSEMENT PARK" doesn't let you access it. Amazing Zone can't be accesed either, bur the two remaining Zones can. So, essentially, they're taken out of world entrance because they aren't complete yet.

There's a level specifically labeled "NOT USED" in Stage Select. I'm not sure exactly what that proves, but it's probably either a deleted level, or an empty level slot (since some levels are missing here and there).

The Bonus Stage crashes after very little time, and I didn't notice much different, apart from a monitor being a clock and another just a circle with the word "UP" on it. (screen below)

Posted Image

The Special Stage has transparent checkerboard floors that while flickering becomme yellow again (as in, half the squares are transparent when you do find the checkerboards), and at one point, the junction from the tube to the "outside" part, there's a huge-ass hole. There's no limits, nor rings, it's all empty. There's issues with the way the tube bits (3D models) are connected, and you can sometimes see a black line, especially when it goes diagonally down. The level just repeats itself until you fall, you can't run out of rings. Seems to be the most glitchless stage, the only one that doesn't crash the emulator after a couple seconds.

Posted Image
Checkerboards.

Posted Image
Outside area.

Posted Image
Junction glitches. This probably happens in the final too.

Marina Madness' Act 4 boat doesn't move, nor does Act 5's.

As with the final, the backgrounds undergo colour changes and whatnot depending on the time of day selected, exceptuating Amazing Arena, which just changes a window's colour. This was probably changed in the final, IIRC. Here's the ones from Botanic Base, the only one I've got working as of yet. However, half of them are the same colour, one of them glitching, and two just change the clouds. The Night ones flicker through green, pink, purle and brown light colours, the waterfalls do this too for some arbitrary reason. Ah, it's easier just to post screens:

Posted Image
Early Morning.

Posted Image
Late Morning.

Posted Image
Early Day.

Posted Image
Late Day (notice how only the clouds turn red).

Posted Image
"Early Sun Set"

Posted Image
"Late Sun Set" (Same shit, different name)

Posted Image
Early Night (notice the green waterfall)

Posted Image
Late Night. Once again, same shit, different name.

In World Entrance, right before you do that World entering malarkey, there's a Speed Monitor underground. I have no fucking clue what that's doing there.

Posted Image
The mystery monitor.
This post has been edited by Nabaztag: 24 February 2008 - 11:16 AM

#15 User is offline Armada 

Posted 24 February 2008 - 11:24 AM

  • Sometimes I do things
  • Posts: 338
  • Joined: 05-January 07
  • Gender:Male
  • Wiki edits:12
QUOTE (Cinossu ◕Д◕ @ Feb 23 2008, 07:51 PM) [post="179918"]Posted Image
Posted Image

aaaaaaa[/quote]
Well, that proves the Sonic and Tails were both supposed to be in, and past Crackers as well. Also, I laughed at how Bomb has the S1 art.
This post has been edited by Armada: 24 February 2008 - 11:24 AM

  • 13 Pages +
  • 1
  • 2
  • 3
  • Last ►
    Locked
    Locked Forum

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users