Sonic and Sega Retro Message Board: SFC won't show anything - Sonic and Sega Retro Message Board

Jump to content

Hey there, Guest!  (Log In · Register) Help
Loading News Feed...
 
Page 1 of 1

SFC won't show anything Nothing wrong with Carts..

#1 User is offline 아힝흥행 

Posted 23 March 2012 - 06:18 AM

  • Posts: 97
  • Joined: 08-March 11
  • Gender:Male
  • Location:Korea/Canada
  • Project:A fan movie that is about 10 minute
So, I just dusted off my SFC and tried to play turtles in time... I realized I didn't have the component cables, so I went out and bought a Gamecube Multi cable thingy that has the S-Video.

My power supply is 220v oddly enough, I couldn't find the original supply. But, I remember that not being a problem.

Turn it on, Nothing appears, I don't think its the Cartridge. I honestly don't know what is wrong.

#2 User is offline Chibisteven 

Posted 23 March 2012 - 06:35 AM

  • Posts: 919
  • Joined: 20-August 08
  • Gender:Male
  • Location:US
  • Wiki edits:11

View Post아힝흥행, on 23 March 2012 - 06:18 AM, said:

So, I just dusted off my SFC and tried to play turtles in time... I realized I didn't have the component cables, so I went out and bought a Gamecube Multi cable thingy that has the S-Video.

My power supply is 220v oddly enough, I couldn't find the original supply. But, I remember that not being a problem.

Turn it on, Nothing appears, I don't think its the Cartridge. I honestly don't know what is wrong.


The SFC doesn't have component cables, they're composite cables. Just sounds like a crappy cable to me. As the design could be causing inpendence issues with other consoles attached to it or if I'm reading this wrong... It could just be the cable is bad and not passing on a signel. I can't recall if SFC had S-Video output to begin with... Someone who knows more about the SFC could help you with that.

Try cleaning the cartridge slot and the game first and checking the seating of the slot (could be worn, too).

#3 User is offline 아힝흥행 

Posted 23 March 2012 - 06:38 AM

  • Posts: 97
  • Joined: 08-March 11
  • Gender:Male
  • Location:Korea/Canada
  • Project:A fan movie that is about 10 minute

View PostChibisteven, on 23 March 2012 - 06:35 AM, said:

View Post아힝흥행, on 23 March 2012 - 06:18 AM, said:

So, I just dusted off my SFC and tried to play turtles in time... I realized I didn't have the component cables, so I went out and bought a Gamecube Multi cable thingy that has the S-Video.

My power supply is 220v oddly enough, I couldn't find the original supply. But, I remember that not being a problem.

Turn it on, Nothing appears, I don't think its the Cartridge. I honestly don't know what is wrong.


The SFC doesn't have component cables, they're composite cables. Just sounds like a crappy cable to me. As the design could be causing inpendence issues with other consoles attached to it or if I'm reading this wrong... It could just be the cable is bad and not passing on a signel. I can't recall if SFC had S-Video output to begin with... Someone who knows more about the SFC could help you with that.

Try cleaning the cartridge slot and the game first and checking the seating of the slot (could be worn, too).


Actually I was just about to edit that to Composite cables. oops :v: Well, I asked Kiddo and he said "Gamecube S-Video cables should work fine with the SFC" so yes, the S-Video for SFC exists :v:

Page 1 of 1
    Locked
    Locked Forum

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users