Sonic and Sega Retro Message Board: Package problems on Ubuntu 11.10 - Sonic and Sega Retro Message Board

Jump to content

Hey there, Guest!  (Log In · Register) Help
Loading News Feed...
 
Page 1 of 1

Package problems on Ubuntu 11.10 I'm not really sure what's going on...

#1 User is offline kazade 

Posted 01 October 2011 - 04:33 AM

  • Posts: 64
  • Joined: 16-March 10
  • Project:A 2D Physics Engine
Hey,

Over the last few weeks I've been testing the beta of Ubuntu 11.10 which is the first release with the new "multiarch" support. Multiarch basically means that you can install i386 packages on an AMD64 system - which is cool..

However, I've noticed that the Gens/GS i386 package refuses to install on AMD64. In previous releases this would just require the ia32-libs package, but I've tried everything I can think of with no joy :(

Here's the output when trying to install the package:

kazade@Hydrogen:~/Downloads$ sudo dpkg -I Gens_2.2.16.7_i386.deb 
[sudo] password for kazade: 
Selecting previously deselected package gens:i386.
(Reading database ... 270884 files and directories currently installed.)
Unpacking gens:i386 (from Gens_2.2.16.7_i386.deb) ...
dpkg: dependency problems prevent configuration of gens:i386:
 gens:i386 depends on libsdl1.2debian (>= 1.1.3); however:
  Package libsdl1.2debian:i386 is not installed.
 gens:i386 depends on xdg-utils; however:
dpkg: error processing gens:i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:
 gens:i386



After that, running "sudo apt-get install -f" removes gens:i386 because it can't resolve the dependency on xdg-utils:i386 (which I think is because xdg-utils is an architecture independent package).

So, this is sort of a semi-bug-report, because all future versions of Debian and Ubuntu will be multiarch. But also a request for any kind of workaround... I didn't realize how much I used Gens until I couldn't use it :D

#2 User is offline GerbilSoft 

Posted 01 October 2011 - 07:54 PM

  • RickRotate'd.
  • Posts: 1953
  • Joined: 11-January 03
  • Gender:Male
  • Location:USA
  • Project:Gens/GS
  • Wiki edits:158
Try installing the libsdl1.2debian:i386 package, then install Gens/GS again.

#3 User is offline kazade 

Posted 02 October 2011 - 01:35 AM

  • Posts: 64
  • Joined: 16-March 10
  • Project:A 2D Physics Engine
I tried, still no joy :(

Quote

kazade@Hydrogen:~/Downloads$ sudo dpkg -I Gens_2.2.16.7_i386.deb
Selecting previously deselected package gens:i386.
(Reading database ... 274208 files and directories currently installed.)
Unpacking gens:i386 (from Gens_2.2.16.7_i386.deb) ...
dpkg: dependency problems prevent configuration of gens:i386:
gens:i386 depends on xdg-utils.
dpkg: error processing gens:i386 (--install):
dependency problems - leaving unconfigured
Processing triggers for gnome-menus ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:
gens:i386


I think this is the problem:

Quote

kazade@Hydrogen:~/Downloads$ sudo apt-get install xdg-utils:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package xdg-utils:i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'xdg-utils:i386' has no installation candidate



xdg-utils (without the :i386) is installed already.

#4 User is offline GerbilSoft 

Posted 02 October 2011 - 08:04 PM

  • RickRotate'd.
  • Posts: 1953
  • Joined: 11-January 03
  • Gender:Male
  • Location:USA
  • Project:Gens/GS
  • Wiki edits:158

View Postkazade, on 02 October 2011 - 01:35 AM, said:

I think this is the problem:

Quote

kazade@Hydrogen:~/Downloads$ sudo apt-get install xdg-utils:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package xdg-utils:i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'xdg-utils:i386' has no installation candidate



xdg-utils (without the :i386) is installed already.

Looks like I need to modify the Debian control file to handle multi-arch properly.

I really don't want to do another release of Gens/GS, but I guess I'll take a look later.

#5 User is offline Miles Prower 

Posted 24 October 2011 - 08:26 AM

  • Renard
  • Posts: 630
  • Joined: 25-January 03
  • Gender:Male
  • Project:HRA
  • Wiki edits:1
I'd love it too. I'm having the same issue.

I managed to get it to run on Oneiric beta, thanks to the iaa32 libs, but that totally broke the whole package management system for some reason. I did try on the final 64bit build, but seeing the issue persisted, I did not want to insist and just did not install it yet.

Page 1 of 1
    Locked
    Locked Forum

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users