Sonic and Sega Retro Message Board: Suddenly KEGA is slow - Sonic and Sega Retro Message Board

Jump to content

Hey there, Guest!  (Log In · Register) Help
  • 3 Pages +
  • 1
  • 2
  • 3
    Locked
    Locked Forum

Suddenly KEGA is slow

#31 User is offline Brainulator 

Posted 10 May 2017 - 04:50 AM

  • Regular garden-variety user
  • Posts: 229
  • Joined: 11-October 15
  • Gender:Male
I'd say the latter would be more appropriate, since we are discussing the technical side of a desktop application. Truthfully, I don't think it's mini-modding if you phrase it as a suggestion or question and not a command.

EDIT (so as to annoy no one: redhotsonic answered my question via PM :specialed: )
This post has been edited by Brainulator: 10 May 2017 - 01:43 PM

#32 User is offline King 

Posted 10 May 2017 - 02:44 PM

  • Posts: 601
  • Joined: 24-January 04
  • Gender:Male
  • Location:United States
I was wondering that myself. Also the Regen on Windows 10 topic could probably be moved as well.

#33 User is offline Chibisteven 

Posted 12 May 2017 - 01:39 AM

  • Posts: 1240
  • Joined: 20-August 08
  • Gender:Male
  • Location:US
  • Wiki edits:11
It runs a solid 60 FPS full screen on my computer (using an i5 7500 Processor, 16 GB RAM, AMD Radeon RX 480 8GB).

Some settings to try in the config file:
ForceCompatibleGFX=0
CompatibleGFXOpt=0
EnhancedGFXOpt=0
ForceFullScreen32=1
VistaAeroIgnore=1
VistaNoWndVSync=1
DebugFlags=0,0,2,2

Under options make sure both "High Priority" and "Alternate Timing" are enabled.
This post has been edited by Chibisteven: 12 May 2017 - 01:48 AM

#34 User is offline DarkVDee 

Posted 12 May 2017 - 10:34 PM

  • Vampire Pixel Artist
  • Posts: 299
  • Joined: 08-November 15
  • Gender:Male
  • Location:California
  • Project:Sonic: Haven Home World

View PostChibisteven, on 12 May 2017 - 01:39 AM, said:

It runs a solid 60 FPS full screen on my computer (using an i5 7500 Processor, 16 GB RAM, AMD Radeon RX 480 8GB).

Some settings to try in the config file:
ForceCompatibleGFX=0
CompatibleGFXOpt=0
EnhancedGFXOpt=0
ForceFullScreen32=1
VistaAeroIgnore=1
VistaNoWndVSync=1
DebugFlags=0,0,2,2

Under options make sure both "High Priority" and "Alternate Timing" are enabled.


This works really well for me. Now it's playing like how it's suppose to be :) Thanks man

#35 User is offline redhotsonic 

Posted 13 May 2017 - 04:48 PM

  • Also known as RHS
  • Posts: 1584
  • Joined: 31-January 05
  • Gender:Male
  • Location:United Kingdom
  • Project:Sonic Bash!
  • Wiki edits:24

View PostChibisteven, on 12 May 2017 - 01:39 AM, said:

It runs a solid 60 FPS full screen on my computer (using an i5 7500 Processor, 16 GB RAM, AMD Radeon RX 480 8GB).

Some settings to try in the config file:
ForceCompatibleGFX=0
CompatibleGFXOpt=0
EnhancedGFXOpt=0
ForceFullScreen32=1
VistaAeroIgnore=1
VistaNoWndVSync=1
DebugFlags=0,0,2,2

Under options make sure both "High Priority" and "Alternate Timing" are enabled.


But are you using Windows 10? =P I've had these settings already (except for the Aero bit so thanks for that). But when I tried messing around with the ini before, nothing would work.


But I will say my earlier suggestion:

View Postredhotsonic, on 09 May 2017 - 02:44 AM, said:

Well, since enabling Windows XP and disabling DPI, Kega has been a solid 60fps 99% of the time. It eventually goes to 55fps for about 15 seconds then goes back to 60fps (sounds like a service in the BG slows it down temporarily). Otherwise, it seems to have been fixed. This has also fixed Sonic Time Twisted, but Sonic Heroes was still losing frames (I have a seperate fix for that luckily). So it seems to work for some games. At least that's something.



This has been working for everything except Sonic Heroes. Kega, Sonic fan games, old Windows 95 games, etc, etc, all work fine. In the extreme rare case, it will lose some frames again and go to 55fps for a few seconds then go back to a solid 60fps. So I think I can safely say, I'm now satisfied :)

Thanks for all the advice, guys!

#36 User is offline King 

Posted 14 May 2017 - 06:10 AM

  • Posts: 601
  • Joined: 24-January 04
  • Gender:Male
  • Location:United States
While I had perfect frame rates on Windows 10 already, the above settings did allow my Kega Wine on Linux copies to obtain full speed without issues so thank you for that. Sadly, that performance increase didn't apply to Wine on macOS (yet, I think it's the Wine version at fault here).

EDIT: Fixed Kega on macOS, YAY! Kega running on Windows, macOS (with Wine), Arch Linux (with Wine) and Ubuntu (with Wine) run perfectly now.
This post has been edited by King: 14 May 2017 - 09:55 AM

#37 User is offline Herm the Germ 

Posted 15 May 2017 - 05:08 AM

  • Hmm, not bad. Well done, doctor!
  • Posts: 1482
  • Joined: 22-April 09
  • Gender:Male
  • Location:Dresden, Saxony, Germany
  • Project:MIDI-to-SMPS-conversions, mostly. Takin' requests, too.
  • Wiki edits:5

View PostKing, on 14 May 2017 - 06:10 AM, said:

Fixed Kega on macOS, YAY!

Might be interesting to some people on here to know what you did to do so. o3o

#38 User is offline King 

Posted 15 May 2017 - 08:42 AM

  • Posts: 601
  • Joined: 24-January 04
  • Gender:Male
  • Location:United States

View PostHerm the Germ, on 15 May 2017 - 05:08 AM, said:

Might be interesting to some people on here to know what you did to do so. o3o

Use PlayOnMac, download and install 2.5-staging (via Manage Wine versions), create a new virtual drive for Kega/emulators, don't use any Winetricks, add Kega's folder of executables and needed files somewhere on the virtual drive (I use Program Files - also set the settings above in Fusion.ini if one is created), under Configure Wine for the virtual drive go to the Staging tab and enable all three available settings.

From there, open Kega, enable alternate timing and high priority and go to the races. Works great.
This post has been edited by King: 15 May 2017 - 08:42 AM

#39 User is offline Meat Miracle 

Posted 27 June 2017 - 06:05 PM

  • Posts: 1634
  • Joined: 11-January 03
  • Gender:Male
  • Wiki edits:2
The only problem I have with Kega on Win10 is that windowed mode seems to skip a ton of frames despite saying 60fps, and that fullscreen switching takes something like 5 seconds. I chalk up both of these to videocard drivers, since it affects quite a bunch of other stuff too. Other than that it works perfect, no compatibility options are used at all, everything works properly.

An updated with proper direct2d window mode and borderless fullscreen would be indeed great.

#40 User is offline ashthedragon 

Posted 12 February 2018 - 01:49 AM

  • Dragon Team
  • Posts: 1324
  • Joined: 23-February 08
  • Gender:Female
  • Location:Spain
  • Project:Sonic Paradise & Sonic Ages
Sorry to bump this but I'm having some trouble with Kega Fusion, running under Win 7. I put Kega on a fresh Win 7 install, but for some reason it is skipping frames. Also, half of the video options are gone, you can only select between TV mode, Scanlines mode, double and normal rendering modes. No force NTSC aspect or any other video options. I tried Chibisteven's config commands and it runs at 60hz now ( it was stuttering between 58-60) but it is still missing frames for some reason. Any help?
This post has been edited by ashthedragon: 12 February 2018 - 01:52 AM

#41 User is offline Neo 

Posted 12 February 2018 - 07:08 AM

  • Clackerjack
  • Posts: 1382
  • Joined: 10-December 04
  • Gender:Male
  • Location:Portugal
  • Project:Sonic 3 Unlocked
  • Wiki edits:1
Open up Fusion.ini and where it says ForceCompatibleGFX=1, set that to 0. For some reason, Fusion sometimes takes a while to start up, and I guess it thinks you don't have a video card or something and shuts off most of the video options.
This post has been edited by Neo: 12 February 2018 - 07:09 AM

#42 User is offline ashthedragon 

Posted 12 February 2018 - 09:56 PM

  • Dragon Team
  • Posts: 1324
  • Joined: 23-February 08
  • Gender:Female
  • Location:Spain
  • Project:Sonic Paradise & Sonic Ages
well, actually... I had trouble installing my video card drivers, so it might be that. Thanks!

#43 User is offline ashthedragon 

Posted 13 March 2018 - 12:35 AM

  • Dragon Team
  • Posts: 1324
  • Joined: 23-February 08
  • Gender:Female
  • Location:Spain
  • Project:Sonic Paradise & Sonic Ages
Sorry to bother again, but I'm having trouble with Kega Fusion one more time. Now, it is about movie recording.

It's on a different PC than the one I asked before, so forget about the other question. It's running Windows 10, and since a few days ago, I was using Kega Fusion to record movies totally fine. I recorded them, and then re-encoded them back using Windows Movie Maker to make them .mp4 and use them with Davinci Resolve, my usual video editor. But since a few days ago, when I record a .avi with fusion, it only records audio. It makes a .AVI file, but when I run it, it's only a black screen with the audio. If I put it at Windows Media Maker, the video shows up, but Davinci does not recognize the video even if I re-compress it with WMM ( it did before). I tried reinstalling Kega KGV drivers, but it is still the same. Also downloaded VIrtual Dub, but files are HUGE ( around 9 GB!), if I choose a Normal or Fast video processing it does make smaller files, but the black screen is still there, only full video processing fixes that.

What do you recommend? I would prefer to keep using Kega as before, why did it go to shit all of the sudden?

#44 User is offline winterhell 

Posted 13 March 2018 - 08:38 AM

  • Posts: 1151
  • Joined: 16-October 10
  • Gender:Male
Perhaps you need to install the video codec? The file is
Fusion364\Video Codec\KegaGameVideo.inf
You right click on it and click Install.

#45 User is offline Neo 

Posted 13 March 2018 - 08:47 AM

  • Clackerjack
  • Posts: 1382
  • Joined: 10-December 04
  • Gender:Male
  • Location:Portugal
  • Project:Sonic 3 Unlocked
  • Wiki edits:1
Also, the Kega VFW codec is 32-bit only, so the video won't play back on 64-bit programs.

  • 3 Pages +
  • 1
  • 2
  • 3
    Locked
    Locked Forum

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users