Sonic and Sega Retro Message Board: Sonic CD (2011) Post-Release Bugs/Fixes/Suggestions - Sonic and Sega Retro Message Board

Jump to content

Hey there, Guest!  (Log In · Register) Help
  • 39 Pages +
  • ◄ First
  • 37
  • 38
  • 39
    Locked
    Locked Forum

Sonic CD (2011) Post-Release Bugs/Fixes/Suggestions

#571 User is offline Elliot Gindi 

Posted 16 August 2016 - 12:26 AM

  • Posts: 91
  • Joined: 21-May 14
  • Gender:Male
  • Location:New York
  • Project:Brawl Minus
Direct Input support would be nice.

#572 User is offline 360 

Posted 16 August 2016 - 05:26 PM

  • Daft Punk Overdrive
  • Posts: 1476
  • Joined: 22-September 10
  • Gender:Male
  • Location:United Kingdom
  • Project:Sonic Neon
Regarding performance from what I remember Taxman's Retro Sonic engine is impeccably coded and actually managed to run on my 400 Mhz Celeron processor at the time with something like 64 MB of RAM. That was the Egg Garden demo from circa 2001 if anyone's interested. Point is - the engine can run on a toaster and therefore CD should too.

#573 User is offline D.A. Garden 

Posted 30 December 2016 - 09:21 PM

  • Posts: 609
  • Joined: 25-June 08
  • Gender:Male
  • Location:England
  • Wiki edits:44
Apologies for the bump, but I had to ask this, in case I wasn't the only one with the issue:

I have recently updated my phone from a Sony Xperia E3 to a Sony Xperia XA and while Sonic CD works fine, the audio has this weird delay issue on everything. It was also an issue on the older phone, but it was minimal, whereas this new phone is about 0.3-0.5 seconds, so it's now enough to be a little distracting. It's also a little odd that it's a persistent issue with Sony Phones (by the looks of it) and nothing else, as it runs on my Mum's Amazon Fire fine with no audio issues (a much older device, with less power behind it, no less).

I'm just curious if anyone else has this (or a similar issue) and if there's a way to fix it?

#574 User is offline Turbohog 

Posted 30 December 2016 - 11:09 PM

  • Posts: 458
  • Joined: 25-June 08
  • Gender:Male
  • Wiki edits:22
I had the game on my iPhone and never had the issue. Can't say anything about the android port. Still want to buy it, but it seems like the Android version has been abandoned.

#575 User is offline .Luke 

Posted 31 December 2016 - 01:37 AM

  • Posts: 2078
  • Joined: 30-March 12
  • Gender:Male
  • Location:United States
  • Project:Freedom Planet fan art; Learning Music Theory
It seems like the only way to buy this game on Android right now is through Amazon's app. What's the background performance hit from that app, I wonder? It requested more permissions than I was comfortable giving to it, no idea what all it needed them for.

#576 User is offline Turbohog 

Posted 31 December 2016 - 01:00 PM

  • Posts: 458
  • Joined: 25-June 08
  • Gender:Male
  • Wiki edits:22
I believe the app requires a connection to Amazon, and hence the Internet. That really bugs me.

@D.A. Garden, are you using the amazon version? Or an old google play version?

#577 User is offline D.A. Garden 

Posted 31 December 2016 - 02:08 PM

  • Posts: 609
  • Joined: 25-June 08
  • Gender:Male
  • Location:England
  • Wiki edits:44
I am trying to play the last release on the Google Play Store that I have access to. As I bought it a long time ago, it's still available to me through previous downloads up to the last release.

#578 User is offline .Luke 

Posted 31 December 2016 - 02:23 PM

  • Posts: 2078
  • Joined: 30-March 12
  • Gender:Male
  • Location:United States
  • Project:Freedom Planet fan art; Learning Music Theory
Which version of Android do you have? Kitkat, Lollipop, Marshmallow? Lots of stuff is breaking on Marshmallow, or there are new apps that only work on it. Not sure if the OS would cause any problems, but sometimes it does.

View PostTurbohog, on 31 December 2016 - 01:00 PM, said:

I believe the app requires a connection to Amazon, and hence the Internet. That really bugs me.


That is a bit of a bother, but at this point, I'll take what I can get. Sonic Mania is not going to release for a while, so what time Taxman and Co could put towards fixing this is non-existent. My biggest concern is whether there's a performance tax for having the Amazon app or its services running in the background.

Or the worse possibility that Google has completely forgotten about it, if an update was submitted. It would not surprise me.

#579 User is offline D.A. Garden 

Posted 31 December 2016 - 03:08 PM

  • Posts: 609
  • Joined: 25-June 08
  • Gender:Male
  • Location:England
  • Wiki edits:44
My new Xperia XA is on Marshmallow and my old Xperia E3 was on KitKat. Although, the issue is on both devices with varying degrees of audio lag. I really don't have any idea what the issue is.

It seems that after some further tinkering with my new phone, I seemed to have fixed the audio lag issue. I enabled 'Developer Options', then set all of the 'Animation Scale' settings to 'None', then back to '1x'. The audio is now playing correctly without lag.
This post has been edited by D.A. Garden: 24 January 2017 - 05:06 AM

  • 39 Pages +
  • ◄ First
  • 37
  • 38
  • 39
    Locked
    Locked Forum

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users